Это приложение разработано для более старой версии oc android как исправить

В коде последней версии Android P Developer Preview 1 разработчики нашли новый класс, который содержит версию API. В случае, если у приложения версия API более старая, чем указано в классе, операционная система выдаст предупреждающее сообщение: «Это приложение было создано для более старой версии Android и может не работать должным образом. Попробуйте проверить наличие обновлений или обратитесь к разработчику». В текущей сборке Android P указана версия API 17, что соответствует Android 4.2 Jelly Bean. Таким образом, приложения, которые были написаны для API более ранних версий, могут работать нестабильно (или вообще не работать).

Нам еще предстоит выяснить, останется ли это предупреждение в финальной сборке Android P, а также какой характер оно в итоге будет нести: сугубо информативный, или же запуск более старых приложений будет автоматически блокироваться системой? Компания Google уже продемонстрировала свою позицию в отношении перехода приложений на последние версии API в своём официальном магазине Play Store, где установила минимально поддерживаемую версию API для последних загруженных приложений. Таким образом, все недавно загруженные приложения должны нормально работать на последних версиях Android . Что же касается более старых приложений, разработчики которых не спешат с обновлением, могут быть навсегда удалены из маркета.

Приложения, настройки, информация